Author Topic: iPhone Optimized Theme  (Read 9410 times)

Sean

  • Administrator
  • Thanks: 241
iPhone Optimized Theme
« on: March 01, 2011, 09:09:20 am »
This looks pretty awesome:
http://smf-media.com/smf4mobile/

 


It's a new SMF theme that's optimized for mobile Safari (and other smart phone browsers). SMF detects the browser and the theme is automatically fed to the mobile browser with the option to switch to the traditional theme.

Cost is $20/year. If there's interest (i.e., $) I'd be happy to purchase it. Say if 10 of us put in just 2 or 3 dollars each (to account for PayPal fees). Think of it as the price of a cheap app for at least a year's worth of iPhone optimized Diabolo.ca. We could run this simultaneously with or instead of the Tapatalk framework.

A couple major advantages to this: (1) it doesn't require a separate application (for this reason I rarely use the Tapatalk app) and (2) it allows the ability to post, which the Tapatalk app restricts without the paid version.

Anyone else in?

Toddyupa

  • Thanks: 35
Re: iPhone Optimized Theme
« Reply #1 on: March 05, 2011, 09:53:35 pm »
That looks pretty awesome...
pretentious 12 year old

Sean

  • Administrator
  • Thanks: 241
Re: iPhone Optimized Theme
« Reply #2 on: April 28, 2012, 02:55:53 am »
I've purchased this theme for the forum. Let let know what you think. It should appear by default when you access diabolo.ca from an iPhone or other smart phone. You can switch back to the full forum view via a link at the bottom of the screen.

Tapatalk should still work too.

Mediaboy13

  • Thanks: 27
Re: iPhone Optimized Theme
« Reply #3 on: April 28, 2012, 03:30:57 am »
Sounds cool Sean and looks awesome  ;)
Thanks

-Alex
I used to have an open mind, but my brains kept falling out.

barnesy

  • Administrator
  • Thanks: 19
Re: iPhone Optimized Theme
« Reply #4 on: April 28, 2012, 09:33:48 am »
hi Sean,

Had a few oddities on my Android tablet.   I got the new theme on first load, then a 404 when trying to use the normal view link.   Pressing login on the new theme gives the normal login page and once I'm logged in, it all seems to work fine but with no sign of the new theme!  Will have a look on my iOS devices in a bit.

edit - sort of similar on the iphone, but without the 404.  I'm on the forum default theme so don't yet see what I'm missing!
Dave

Sean

  • Administrator
  • Thanks: 241
Re: iPhone Optimized Theme
« Reply #5 on: April 28, 2012, 11:16:32 pm »
Hmm, I'm not getting that on an iPhone. The normal view link works, when I log in I stay in the mobile view, and I can switch back with the mobile link at the bottom. Does the 404 happen repeatedly or was it a one-time thing?

Do you see this link at the bottom?

barnesy

  • Administrator
  • Thanks: 19
Re: iPhone Optimized Theme
« Reply #6 on: April 28, 2012, 11:45:35 pm »
Ah, that link will be the first thing I should have spotted!

It works here on my laptop but on my iOS and Android devices it gives a 404, which seems to be happening in whatever handles the link.   That is, the link seems to be the same, but while it works on the laptop, it ends up at /forum/action=forum on my other devices.  So I wonder if something is set assuming that it will work out the default page but then it doesn't? 

edit - and it seems to behave OK if I edit the page name into the URL

Sean

  • Administrator
  • Thanks: 241
Re: iPhone Optimized Theme
« Reply #7 on: April 30, 2012, 05:14:32 am »
I wonder if it depends which page you start from when you click the link. E.g., is it a thread page, the main forum page, ...? Could be something to do with the main URL redirect to /forum or the simpleportal setup. Also, is this when you're logged in?

Anyone else found places where it isn't working?

I don't think the theme works that well on a bigger screen like an iPad. Still not sure if I like it on an iPhone. Looks pretty, but I feel disoriented and have trouble figuring out how to do things.

barnesy

  • Administrator
  • Thanks: 19
Re: iPhone Optimized Theme
« Reply #8 on: April 30, 2012, 07:28:25 pm »
Aha!  It seems the link works from a thread, but not from the forum index page, which is the one I now realise I would go back to each time I tried to click the link!   Same happens when changing the other way too.   I don't think logged in status has changed it for me.

I'm also not sure what I think of it on the iPhone.   The concept appeals to me, but it doesn't seem clear.   I'm not sure if that's because it lacks visual clarity or if it is just a bit too different for my change averse ways!  I'll continue to give it a go and see.

Sean

  • Administrator
  • Thanks: 241
Re: iPhone Optimized Theme
« Reply #9 on: April 30, 2012, 11:11:40 pm »
Ah, I see. Good find. I've posted in the support forum.