Author Topic: Forum page layout issues  (Read 2257 times)

Chiok

  • Donator
  • Thanks: 12
Forum page layout issues
« on: December 27, 2008, 03:43:03 PM »
Having taken a hiatus from the forum for a while, I come back and see some nice changes and everything still looking nice and swish (thank you Sean).

However the changes seem to have done something funny to the layout I see on my screen.  Firstly, people's posts seem to appear underneath a break line below their avatar instead of alongside their avatar.  If the member doesn't have an avatar, the post shows up in the right place, but if they do, then it skooches all the way underneath (i.e. taking up more vertical space).

Secondly, the quick reply box seems to have lost it's right hand side off the end of the screen so that when I type into it, the text disappears off the right for about 20 characters or so and then goes to the next line.  It's as if the reply box is too big to fit (my screen resolution is 1200x800, so no lack of space there).

I will say that this might be an issue due to myself still using Internet Explorer 6 (I feel no need to upgrade).  It looks fine on Firefox though.  It used to all look fine, but now it's gone a bit skew-if like the layout isn't as backwards compatitible?

Anyone else have similar issues?  I mean, a fix would be nice, but I can live with it, just wondering what is making it do this.

Chiok
www.gravityvomit.co.uk - Gravity pulls down, we throw up.
University of Bath Juggling and Circus Skills

Sean

  • Administrator
  • Thanks: 241
Re: Forum page layout issues
« Reply #1 on: December 27, 2008, 03:56:05 PM »
My guess is it's simply a function of having migrated to SMF 2.0 (beta 4) from SMF 2. Much of the template and style filed were re-written. There is hope that these issues will be fixed in future betas or release candidates. There's a growing trend in webdesign to ignore IE6 in development. The browser is so quirky in it's rendering that coding to look perfect in it as well as all the other browsers, which are generally standards compliant, is too much work.

There are a couple little quirks in the template for other browsers, but the best advice would be to use a recent, standards compliant, more secure, more feature rich, and significantly faster browser be that IE7 (or much better still IE8), Firefox, Opera, Chrome, Camino, or Safari. 

William

  • VotW Contributor
  • Thanks: 46
Re: Forum page layout issues
« Reply #2 on: December 28, 2008, 01:11:16 AM »
Yeah I've had all the exact same problem on my school pc's. But with Firefox, IE7/IE8 and Google Chrome its all fine.
William - YouTube! "NO! If they're blue, you should not touch your nuts." - Aaro

Chiok

  • Donator
  • Thanks: 12
Re: Forum page layout issues
« Reply #3 on: December 29, 2008, 02:20:59 PM »
Ah, that makes sense.  IE6 is becoming a rather dated piece of software so I can understand that it would fall on the wayside of development for new things.  Maybe I'll upgrade it, I've only just recently come around to the idea of "tabs".

Thanks for your help Sean, I shall grin and bear it for now in classic British sensibility

Chiok
www.gravityvomit.co.uk - Gravity pulls down, we throw up.
University of Bath Juggling and Circus Skills

 

SimplePortal 2.3.7 © 2008-2021, SimplePortal